Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo,

ich betreibe aktuell die version sosci 2.4.0 mit der php version 5.4.39.
diese soll im Zuge des Serverupdates auf 5.6. und später auf 7.0 gesetzt werden.
Kann ich das ohne Bedenken tun oder gibt es hier Funktionen die nur in den alten php-versionen verwendet werden ?

in SoSci Survey (dt.) by s034083 (110 points)

1 Answer

0 votes

Ich würde dringend ein Update Ihrer SoSci-Installation empfehlen - zwar sind keine schwerwiegenden Sicherheitslücken in der alten Version bekannt, aber Version 2.4.0 ist von 2014 und in den letzten 3 Jahren hat sich sehr, sehr viel an der Software getan.

Die aktuellste Interims-Version erfordert mindestens PHP 5.5, läuft aber auch hervorragend mit PHP 7. Die alte Version 2.4.0 läuft nur mit PHP 5.

Für das Update würde ich folgendes Vorgehen empfehlen:

  1. Backup von Datenbank und Dateisystem.
  2. Aufrufen der SoSci Survey Installationsroutine, damit die Caches aufgelöst/bereinigt werden.
  3. Kurze Mail an info@soscisurvey.de, damit wir die aktuellste Interims-Version bereitstellen.
  4. Update von PHP auf Version 7 (danach läuft SoSci Survey erst einmal nicht mehr).
  5. Update von SoSci Survey durch Kopieren der neuen Dateien ins Installationsverzeichnis.
  6. Aufruf der Installationroutine, damit die Datenbank aktualisiert wird.

Für den unwahrscheinlichen Fall, dass Sie die laufenden Projekte auf SoSci Survey nicht mehr benötigen bzw. Ihne die XML-Archive ausreichen, können Sie SoSci Survey natürlich auf PHP 7 auch einfach neu aufsetzen.

by SoSci Survey (107k points)
Vielen Dank für die Infos
die 2.4. version läuft auch nur noch weil es in der 2.5 (2015 hatte ich ein DEV System gebaut) ein, zwei Funktionen nicht gab die in der 2.4 existierten (details kenne ich leider nicht [ ich mache "nur" die Server Administration].
Ich werde erst einmal auf die 5.6 php migrieren und php 7 mit dem Server komplett neu umsetzen .
...