Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo,

ich habe in meinem Fragebogen 4 verschiedene Videos - 2 mit Ton, 2 ohne.
Alle Videos sind in mp4- und webm-Format hochgeladen und per HTML Code eingebettet, z. B.:

<video width="650" height="426" controls controlsList="nodownload">
  <source src="AM270_v5.mp4" type="video/mp4" />
  <source src="AM270_v5.webm" type="video/webm" />
</video>

Die beiden Videos mit Ton werden nur bei Safari abgespielt, bei Chrome oder Firefox läuft nur der Sound. Die Videos ohne Ton funktionieren bei allen Browsern.
Was kann/ muss ich tun, damit die beiden Videos mit Bild und Ton auf Chrome und Firefox laufen?

Vielen Dank schon einmal im Voraus!!

in SoSci Survey (dt.) by s101204 (110 points)

1 Answer

0 votes

Das Dateiformat selbst sagt noch nichts darüber, wie die Dateien intern kodiert sind - es gibt mehrere sog. "Codecs", die innerhalb der Datei zum Einsatz kommen. Und die Browser sind da ein wenig pingelig.

Vermutlich haben Sie für die Kodierung also einen Codec erwischt, den die Browser nicht mögen. Es ist aber ebenso denkbar, dass beim Multiplexen der Dateien (Vermischen von Ton und Bild) etwas schief gelaufen ist. Lösung 1: Prüfen Sie, welchen Codec Sie benötigen und kodieren Sie die Dateien neu. Lösung 2: Lassen vom Online-Service https://cloudconvert.com/ umkodieren - dieser hat in der Vergangenheit eine recht gute Figur gemacht.

Prüfen Sie auch die Fehlerkonsole des Browsers, um weitere Hinweise zu erhalten.

Wichtig: Wenn der Ton Teil des Stimulus ist, dann weisen Sie die Teilnehmer darauf hin, dass sie den Lautsprecher einschalten. Und setzen Sie zu Beginn des Fragebogens auf jeden Fall ein kurzes Testvideo, um die korrekte Bild- und Tonausgabe zu testen.

by SoSci Survey (238k points)
Ein Video hat funktioniert und läuft jetzt einwandfrei, das andere kriege auf Biegen und Brechen nicht dazu auf Firefox oder Chrome zu laufen. Ich habe alle möglichen Formate oder Codes probiert, die Datei mehrmals kodiert, aber es funktioniert einfach nicht... Gibt es evtl. noch eine weitere Möglichkeit?
Sie sollten erstmal herausfinden, an welcher der beiden Dateien es hakt. Klappt es, wenn Sie die Video-Dateien direkt im Browser öffnen (einfach von der Festplatte ins Browserfenster ziehen)? Was sagt denn der Browser (Fehlerkonsole) dazu, wenn Sie die Website aufrufen? Kodieren Sie die betroffene Datei einmal testweise mit CloudConvert (kostenlos möglich).
Vielen Dank!! Ich musste die mp4 Datei noch einmal neu kodieren und ersetzen, aber jetzt läuft es überall =))) Tausend Dank!
...