0 votes
in SoSci Survey (dt.) by s274830 (120 points)

Hallo!

Ich benötige 2 unterschiedliche Videos in meinem Fragebogen die randomisiert abgespielt werden sollen.
Basierend auf vorherigen Fragen/Antworten habe ich meine Videos so eingefügt:
Bei den Zetteln die URLS als auch den HTML Code von Youtube über "einbetten" eingefügt. Bei den Urls wird mir die Fehlermeldung wie am Foto angezeigt, bei dem HTML Code wird mir "404 not found" angezeigt. Ich habe die Videos aber auf einer anderen Seite bereits eingebettet und abgespielt, das heißt die Links von den Videos waren nicht das Problem.

Seitdem ich versuche die Randomisierung zu erstellen, hänge ich.
Bei Inhalte habe ich folgenden HTML Code eingefügt:

Ich hatte auch schon einen HTML Code von einem der Youtubve Videos eingefügt und "source" zu "random" geändert, ich habe alle vorherigen Fragen und Empfehlungen durchgelesen und weiß gerade trotzdem nicht wo das Problem ist.

Ich würde mich sehr über Hilfe freuen!

1 Answer

0 votes
by SoSci Survey (316k points)

Bei den Urls wird mir die Fehlermeldung wie am Foto angezeigt

Das Vorschaufenster von Fragen erlaubt aus Sicherheitsgründen keine eingebetteten Inhalte. Ziehen Sie die Frage bitte auf eine Seite im Fragebogen und starten Sie den Fragebogen ab dieser Seite, um den eingebetteten Inhalt (in dem Fall das YouTube Video) zu testen.

bei dem HTML Code wird mir "404 not found" angezeigt

Ohne Kenntnis des exakten HTML-Codes kann ich dazu leider keine konstruktive Antwort geben.

by s274830 (120 points)
<iframe width="420" height="315" src="%random%" frameborder="0" allowfullscreen></iframe> ich habe folgenden HTML Code bei "Inhalte anzeigen" eingegeben.
by s274830 (120 points)
Ich habe nun den HTML Code wieder geändert, so dass mir das Youtube Video richtig angezeigt wird (so lässt es sich auch wieder abspielen, wenn ich den Fragebogen teste).

<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/mX-pMA7tiEY?si=81-e-aFBYV4vvUVb" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture; web-share" referrerpolicy="strict-origin-when-cross-origin" allowfullscreen></iframe>

Allerdings zeigt es mir dann ja nur dieses Video und ich habe aber zwei Videos und weiß nicht wie ich die Randomisierung hinbekomme. Da der HTML Code den ich für die Randomisierung (siehe oben) eingegeben habe, falsch zu sein scheint (da dann die Videos nicht mehr sichtbar sind).
by SoSci Survey (316k points)
Wenn Sie den Code wie oben verwenden, müsste im Zufallsgenerator in einer Zeile der komplette YouTube-Link stehen, also

https://www.youtube-nocookie.com/embed/mX-pMA7tiEY?si=81-e-aFBYV4vvUVb

Genau dieser Teil wird dann im HTML-Code durch %random% ersetzt.
asked Jun 19 in SoSci Survey (dt.) by s274830 (120 points)
closed Jun 22 by SoSci Survey
404 not found
by s274830 (120 points)
Das habe ich versucht und es hat nicht geklappt (ich habe den screenshot oben eingefügt, ich konnte ihn nicht hier einfügen).
by SoSci Survey (316k points)
Würden Sie den Zufallsgenerator bitte in einer Seite Ihres Fragebogens ziehen, und dann einen Pretest-Link erstellen, der direkt auf dieser Seite startet? Dann werfe ich mal einen Blick auf das Ergebnis.

Der Screenshot oben hilft nur bedingt weiter, weil ... wie in der Antwort schon geschrieben ... in der Vorschau des Frage kann es nicht funktionieren, erst im Fragebogen.

Update: Pardon, ich habe die "related question" erst nicht gesehen. Machen wir dort weiter. Und posten Sie gerne auch den Pretest-Link dort :)

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...