0 votes
in SoSci Survey (dt.) by s265676 (110 points)

Hi,

we conduct studies with participants with visual impairments or blindness. Thus, we rely on the option to start a questionnaire in the screenreader mode or to switch to the screenreader mode.
Due to central infrastructure we still use sosci version 3.4.00. Since one of the last security updates for sosci survey the screenreader mode is not working anymore (preview, pretest and publishing) and runs into a 500 - internal server error. Therefore, the questionnaire is not usable anymore for participants.

The error log shows:

Error Logfile: Warning: An error occured during PHP-code evaluation: 1: Uncaught Error: Call to undefined method s2survey\questionnaire\QnrPage::htmlScreenreaderButton()

As we cannot update our current sosci survey version due to dependencies in our central infrastructure, is there another hint/tip what we can do?

1 Answer

0 votes
by SoSci Survey (309k points)

Version 3.4.00 has been outdated for more than one year by now: https://www.soscisurvey.de/de/changelog

Please upgrade to the latest version as soon as possible.

As we cannot update our current sosci survey version due to dependencies in our central infrastructure...

There are critical security and functional issues in version 3.4.00, therefore an upgrade is important. Usually SoSci Survey works well with outdated environments.

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...