0 votes
in SoSci Survey (dt.) by s150779 (305 points)
edited by s150779

Ich habe Videos im mp4/webm/ogg-Format in den Fragebogen eingebunden.

Das Abspielen funktioniert am PC sowohl bei Firefox als auch bei Chrome problemfrei.
Das Abspielen funktioniert hingegen am Android-Smartphone lediglich bei Chrome, nicht bei Firefox. Das Abspielen funktioniert ebenso nicht über iOS: Safari.

Ich habe die Entwickler-Tools im Browser verwendet, um die Video-Datei zu untersuchen und konnte so ausschließen, dass es an der Kodierung bzw. dem Dekodieren liegt (vgl. https://www.soscisurvey.de/help/doku.php/de:general:browser-tools#probleme_mit_audio_video).

Woran kann das liegen bzw. wie kann es behoben werden? Wie können die Videos auch auf Smartphones mit Firefox / Safari abgespielt werden?

Hier der Vorschau-Link zur entsprechende Frage: https://sosci.makam.at/an23/?act=x7tE0II7Z1ED4UHqYIrJYU38

1 Answer

0 votes
by SoSci Survey (309k points)

Woran kann das liegen bzw. wie kann es behoben werden?

Haben Sie die Dateinamen schon mal direkt im Firefox auf Anroid aufgerufen? Welche funktionieren, welche nicht?

https://sosci.makam.at/an23/1.mp4
https://sosci.makam.at/an23/1.ogg
https://sosci.makam.at/an23/1.webm

Gleiche Frage für iOS. Wenn einzelne Videos auf den jeweiligen Systemen nicht abspielen, obwohl sie dort abspielen sollten, ist vermutlich bei der Kodierung etwas schief gelaufen. Das lässt sich genauer prüfen, wenn Sie den Fehler auf einzelne Dateien eingrenzen konnten.

by s150779 (305 points)
Danke für die Antwort. Tatsächlich funktionieren alle drei Dateien einwandfrei, wenn ich sie direkt aufrufe. Ich habe ein wenig herumgetestet und habe vielleicht etwas entdeckt, was bei der Diagnose und Beseitigung des Problems hilft.

Zuerst eine kurze Erklärung zu den Videos: Diese sollen automatisch abgespielt werden und nach Ende des Abspielens soll automatisch zur nächsten Seite weitergeleitet werden. Deswegen habe ich bei der Einbindung der Videos einen HTML Code verwendet, der dem jeweiligen Video einen Namen gibt, sodass im weiteren Code auf diesen Videonamen verwiesen werden kann. Der entsprechende Abschnitt, der dem Video 1.webm die id "1" zuweist, schaut so aus:

<video id="1" style="max-width: 100%" muted playsinline >
<source src="1.webm" type="video/webm">     
</video>

Beim Testen habe ich genau diesen Abschnitt id="1" entfernt, sodass der Code nun so ausschaut:

<video style="max-width: 100%" playsinline controls controlsList="nodownload">
<source src="1.webm" type="video/webm">    
</video>

Nun lässt sich das Video einwandfrei auf Android/Firefox abspielen. Jedoch weiß ich nun nicht, wie ich die weiteren Funktionalitäten (autoplay, automatisch weiterleiten) ohne die ID bewerkstelligen kann. Haben Sie eine Idee?

Hier der vollständige Code:

<video id="1" style="max-width: 100%" muted playsinline>
<source src="1.webm" type="video/webm">  
</video>

<script>
document.getElementById("1").play();
</script>

<script type="text/javascript">
<!--
 
var video = document.getElementById("1");
 
 
// -->
</script>

<script>
var aud = document.getElementById("1");
aud.addEventListener("ended", function() {SoSciTools.submitPage()});

</script>
by SoSci Survey (309k points)
> Diese sollen automatisch abgespielt werden und nach Ende des Abspielens soll automatisch zur nächsten Seite weitergeleitet werden.

Auf Mobilgeräten werden Videos oftmals nicht automatisch abgespielt - wenn überhaupt dann ohne Ton (dafür muss man sie aber explizit stummschalten via "mute").

> <video id="1"

Ich bin ziemlich sicher, dass eine HTML-ID nicht mit einer Ziffer beginnen darf. Also besser <video id="v1"...>

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...