0 votes
in SoSci Survey (dt.) by s251247 (110 points)

Hallo,

ich habe durch HTML-Code ein Video in meinem Fragebogen eingebettet. Der Code sieht so aus:

*[kleinerZeichen] video id="testvideo" width = "512" height="288" controls autoplay>
[kleinerZeichen] source src="Wie_viel_Zeit_verbringe_ich_auf_Instagram.mp4" >

[kleiner Zeichen] /video>
[kleiner Zeichen] script type="text/javascript">
[kleiner Zeichen] !--

var video = document.getElementById("testvideo");

// Bedienelemente ausblenden, sobald es abspielt
SoSciTools.attachEvent(video, "play", function(evt) {
testvideo.removeAttribute("controls");
});
// Weiter-Knopf ausblenden
SoSciTools.attachEvent(window, "load", function(evt) {
SoSciTools.submitButtonsHide();
});

// -->
[kleiner Zeichen] /script>
[kleiner Zeichen] script>
var aud = document.getElementById("testvideo");
aud.addEventListener("ended", function() {SoSciTools.submitPage()});
[kleiner Zeichen] /script>*

Obwohl ich "video controls autoplay" nutze, startet das Video bei der Fragebogenvorschau nicht automatisch.

Wo liegt der Fehler?

1 Answer

0 votes
by SoSci Survey (308k points)

Die meisten Browser blockieren das Autoplay, wenn die Nutzer:innen vorher nicht mit der Seite interagiert haben. Sie können es mal mit dem Script aus der Anleitung versuchen (an dem Sie sich vermutlich ohnehin schon orientiert haben), aber am Ende sind Sie auf die Kooperation entweder des Browsers oder der Befragten angewiesen. Letztes sind Sie bei einer Befragung aber ohnehin :)

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...