Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo!

Mir wird im Befragungsprojekt auf einer Seite folgende Fehlermeldung angezeigt: "Items in der nachfolgenden Fragen werden auf dieser Seite schon weiter oben angezeigt. Dies führt fast zwangsläufig zu Datenverlust! Falls Sie eine Frage mehrfach benötigen, legen Sie bitte eine Kopie der Frage an. Betroffen sind folgende Items: ZE01_01".

Das Item "ZE01_01" wurde auf dieser Seite und in der dazugehörigen Frage jedoch nicht verwendet. Wie bekomme ich diese Fehlermeldung weg?

Vielen Dank!

in SoSci Survey (dt.) by s110814 (110 points)
Würden Sie bitte einmal die Debug-Information der betroffenen Seite posten:
https://www.soscisurvey.de/help/doku.php/de:create:debugging

Der häufigste Fehler ist, dass eine Frage in die Seite gezogen und dann nochmal zusätzlich via question() oder show() mittels PHP-Code eingebunden wird.
[Information]    Interview Nummer 73 wird fortgesetzt
[Information]    Der Fragebogen base im Projekt test337354 wird verwendet
[Information]    Die Verweildauer auf Seite 22 betrug zusätzliche 2 Sekunden
[Verarbeitung]    Lese Antworten von Seite 22
[Information]    Keine Antwort für A603
[Information]    Keine Antwort für ZE05_01
[Information]    Fragen bisher zu 0% vollständig beantwortet
[Verarbeitung]    Erstelle Seite 23 in Fragebogen base
[Inhalt]    Erstelle Frage A612

Diese Informationen werden angezeigt. Die Warnung wird dort jedoch nicht angezeigt. Lediglich 3 Mal oberhalb des Items. Auf der Seite befindet sich jedoch nur ein Item.
In der Debug-Information ist nicht die Rede davon, dass ZE01 überhaupt angezeigt werden würde. Steht die Frage ZE01 auf der Seite 23? Und was steht noch alles auf der Seite?

Falls es um eine andere Seite geht, posten Sie gerne deren Debug-Information.

> Auf der Seite befindet sich jedoch nur ein Item.

Normalerweise zieht man ja Fragen in die Seite, keine Items. Meinen Sie eine (komplette) Frage mnit nur einem Item oder haben Sie die Frage in die Seite gezogen und dann per Zahnrad nur eines der Items anzeigen lassen?
Nein, Frage ZE01 befindet sich nicht auf Seite 23. Frage ZE01_01 beinhaltet lediglich wie ZE05_01 ein frei platziertes Eingabefeld, um ein zusätzliches offenes Eingabefeld hinter einer Auswahloption zu haben. Auf Seite 23 befindet sich nur eine Frage (A612) mit ZE05_01 als offenes Eingabefeld hinter einem Item der Frage.

Da habe ich mich missverständlich ausdrückt: es wurde nur die Frage auf die Seite gezogen, kein Item. Die Frage besteht aus mehreren Items.
Nun bin ich ein wenig irritiert, denn die Fehlermeldung bezieht sich auf ZE01:

> Das Item "ZE01_01" wurde auf dieser Seite ...

Liefert ZE01 Eingabefelder für andere Fragen (z.B. für A612) oder beinhaltet ZE01 solche Eingabefelder? Oder hat ZE01 mit der Seite 23 überhaupt nichts zu tun? In dem Fall würde ich nochmal fragen, welche Seite in der Fehlermeldung angegeben wird?
ZE01 liefert für A612 keine Eingabefelder und ZE01 hat mit Seite 23 eigentlich auch nichts zu tun, da ZE01 gar nicht für die Frage auf Seite 23 verwendet wird.

Grundsätzlich liefert ZE01 lediglich auf einer Seite zu Beginn des Fragebogens ein Eingabefeld für eine ganz andere Frage. Die mit der Frage auf Seite 23 jedoch nicht in Verbindung steht.

In der Fehlermeldung steht jedoch obendrüber "Fehler im Fragebogen" (Seite 23). Deshalb ist die Fehlermeldung für mich so irritierend.
> ZE01 hat mit Seite 23 eigentlich auch nichts zu tun

Okay ... dann läuft da irgendwas gründlich schief. Wäre es Ihnen recht, wenn ich mir das einmal direkt ansehe? Ich würde mir dafür einen Administrator-Zugang für Ihr Befragungsprojekt anlegen. Wenn Ihnen das recht ist, teilen Sie bitte den Namen des Befragugsprojekts mit.
Wir konnten den Fehler durch Löschen und Neuerstellung aller frei platzierten Eingabefelder nun beheben und haben dabei entdeckt, dass tatsächlich in einem Item auf Seite 23, das versehentlich ein verstecktes Folgeitem enthielt und nicht direkt angezeigt wurde, ZE01 verwendet wurde. Dennoch vielen Dank für Ihre Mühe!
Bitteschön gerne.

Was hatte es mit dem "versteckten Folgeitem" auf sich? Ein Problem, über welches andere Nutzer:innen auch stolpern könnten?

Please log in or register to answer this question.

...