Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Ich habe in meinem Fragebogen auf jeder Seite ein kurzes audio mittels HTML5 eingebunden, sowohl im mp3 als auch im .ogg-Format. Das audio wird immer automatisch abgespielt, der html code ist wie folgt:

<audio id="audio_with_controls" preload="auto" autoplay>
  <source src="call_2_pause.mp3" type="audio/mpeg" />
  <source src="call_2_pause.ogg" type="audio/ogg" />
  Your browser cannot play this audio file.
</audio>

Bei mir und den meisten Leuten, die den Fragebogen für mich testen, funktioniert das automatische Abspielen wunderbar. Ich selbst habe es in sowohl Firefox als auch Chrome ausprobiert, beides ging. 2 meiner 'Tester' haben mir aber berichtet, dass sie auf jeder Seite einfach überhaupt nichts gehört haben. Anscheinend funktioniert bei ihnen die autoplay-Funktion nicht - denn auf einer Einführungsseite habe ich auch ein audio mittels HTML 5 eingebunden, dass allerdings nicht automatisch abgespielt wird, und das konnten sie ohne Probleme abspielen und anhören:

<audio id="audio_with_controls" preload="auto" controls controlsList="nodownload">
  <source src="Test_audio_3_edited_shortened.mp3" type="audio/mpeg" />
  <source src="Test_audio_3_edited_shortened.ogg" type="audio/ogg" />
  Your browser cannot play this audio file. 
</audio>

Woran kann es liegen, dass das automatische Abspielen nicht bei jedem funktioniert?

in SoSci Survey (dt.) by s088878 (290 points)

1 Answer

0 votes

Die Autoplay-Funktion wird auf mobilen Endgeräten standardmäßig unterdrückt - die Browser achten dort darauf, nicht das Datenvolumen der Teilnehmer zu verschleudern.

Lösung? Binden Sie ein kleines JavaScript ein, welches nach z.B. 1 Sek. die Kontrollelemente einblendet, wenn nichts spielt. Sie haben Ihrem <audio> die ID "audio_with_controls" gegeben, dann nehmen wir auch diese im JavaScript:

<script type="text/javascript">
<!--
window.addEventListener("load", function() {
  window.setTimeout(function() {
    var audio = document.getElementById("audio_with_controls");
    if (audio.paused) {
      audio.setAttribute("controls", "yes");
    }
  }, 250);
});
// -->
</script>

Tipp: Wenn Sie die Audio-Datei in die Seite ziehen, dann auf das Zahnrad klicken um Autoplay zu aktivieren und die Kontrollelemente zu deaktivieren, dann kümmert sich SoSci Survey automatisch um das JavaScript.

by SoSci Survey (82k points)
Hallo, die 2 user haben es aber nicht auf einem mobilen Gerät (smartphone, tablet) probiert, sondern auf einem laptop. Was kann da schief gelaufen sein?

Die Kontrollelemente einzublenden ist für mich leider keine Option - alle Teilnehmer sollen den Stimulus nur 1x hören und keine Möglichkeit dazu haben, ihn nochmals abzuspielen...
Das wiederholte Abspielen können Sie mit anderweitigem JavaScript-Code unterbinden. Aber Tablets a priori auszuschließen, ist sehr riskant.

Wenn es daran nicht lag, dann müssten Sie bitte einmal in Erfahrung bringen, auf welchem Betriebssystem und mit welchem Browser die Tester unterwegs waren. Womöglich ist einer der beiden Dateinamen falsch geschrieben (Groß-/Kleinschreibung)? Wenn sie das Problem replizieren lässt, kann man in der Fehlerkonsole des jeweiligen Browsers nach Details suchen.

Aus können Sie einmal testen, ob das Autoplay bei den Betroffenen funktioniert, wenn Sie die Kontrollelemente anzeigen.
Kann es sein, dass das an einem nicht aktivierten java liegt? Eine Testerin hat rückgemeldet, dass sie Mac bzw. den browser Safari verwendet, und dass bei 'high sierra' java anscheinend nicht mehr vorinstalliert ist...
Nein, JavaScript (Browser) und Java (komplettes Betriebssystem) haben miteinader nichts zu tun. Zumal das Autoplay damit nicht in Verbindung stehen sollte. Ich tippe eher auf einer fehlerhafte Audio-Datei - und während unter einigen Browser/Betriebssystem-Kombinationen die erste Audio-Datei absgespielt wird, ist es auf anderen die andere (evtl. defekte).
Dann müsste aber jede einzelne meiner Audiodateien einen Fehler haben. Denn eine Testperson hat mir berichtet, dass sie gar nichts gehört hat... Bei einer anderen war es ganz komisch: zuerst hat sie nichts gehört. Dann hat sie es etwas später noch einmal probiert, und plötzlich ging es...

Wie könnte ich das denn selbst testen? Dh. welche browser greifen dann auf mp3 u. welche auf .ogg zu?
Fragen Sie die betroffenen Personen am besten direkt, mit welchen Browsern das Problem auftrat.

Wenn es bei einer Person einmal nicht funktionierte und dann schon, dass wird es richtig schwierig. Aber ich hatte ja weiter oben schon einige Möglichkeiten geschildert, das Problem einzugrenzen. Unter anderem das testweise Einblenden der Steuerung für das Audio.

Sie sollten weiterhin einmal testen, ob es bei Ihnen noch funktioniert, wenn Sie den Browser-Cache (Historie) löschen.

>  Dh. welche browser greifen dann auf mp3 u. welche auf .ogg zu?

Das sollte mithilfe einer Suchmaschine Ihrer Wahl schnell zu klären sein.
Also bei Person Nr. 1 trat das Problem bei Chrome auf, und bei einem nochmaligen Versuch ging es dann doch (auch in Chrome). Bei mir funktioniert das Audio in Chrome generell.

Bei Person Nr. 2 trat das Problem in Safari auf (Mac-User). Eine weitere Testerin die auch Mac bzw. Safari benutzt hatte das Problem allerdings nicht.

Bei mir funktioniert das audio in sowohl Firefox als auch Chrome nach löschen der browser history.

Dh. Tabellen wie die folgenden sollten eigentlich Aufschluss geben, oder? Auf welches Format greift ein browser zu, wenn er sowohl ogg vorbis als auch mp3 unterstützt?
mp3: https://caniuse.com/#feat=mp3.
Ogg Vorbis: https://caniuse.com/#feat=ogg-vorbis
Also ... Probleme, die einmalig auftreten und dann (selbst nach Löschen des Cache) nicht mehr, sind kaum zu klären. Womöglich hatten die Tester beim ersten Test eine abbrechende WLAN-Verbindung? Oder Sie haben erst ein falsches mp3 online gehabt, das noch im Browsercache lag? Oder die Datei wurde aufgrund eines Netzwerkfehlers nicht übertragen? Alles Spekulation und ich wüsste noch ein Dutzend mögliche Ursachen. Okay ... manche dvon wären abstrus...
Also ich habe Person Nr. 2 jetzt nochmal gebeten den Fragebogen zu probieren - wieder dasselbe Problem mit Safari (Mac). Daraufhin habe ich ihr eine Alternativversion des Fragebogens gegeben, in dem ich immer mit dem obigen Javascript die Kontrollelemente eingeblendet habe, wenn nichts spielt. Mit den Kontrollelementen konnte sie dann die audios abspielen und hat alles gehört. Dh. es liegt wohl - zumindest in diesem Fall - wirklich am autoplay, das nicht funktioniert... Könnte man das irgendwie beheben? (Die Lösung mit den Kontrollelementen ist für meine Zwecke nicht geeignet da die Teilnehmer ein ziemlich enges Zeitlimit auf jeder Seite haben, u. Zeit verlieren, wenn sie das Audio erst selber starten müssen...).
Ich würde nicht ausschließen, dass Safari das autoplay absichtlich blockiert (sowohl direkt wie auch via JavaScript), z.B. https://www.macworld.co.uk/how-to/mac-software/how-stop-autoplay-video-in-safari-chrome-on-mac-3661342/

Hier habe ich noch eine News-Meldung gefunden (https://techcrunch.com/2017/06/05/auto-play-block/):

> Apple adds auto-play video blocking to desktop Safari

Wenn der Browser das Autoplay nicht will, sieht es schlecht aus. Ich bezweifle, dass man das einfach umgehen kann, wenn sich selbst Google damit schwer tut. Dann bleibt nur, mit einer Frage "Gerät und übermittelte Variablen" den Browser-Typ zu speichern.

Wenn Sie Videos einsetzen, sollten Sie zu Beginn ohnehin ein Testvideo abspielen. Etwa eines, das eine Zahl zeigt, die man dann in ein Eingabefeld eintragen muss. Wenn es schon dort nicht funktioniert, ist der Teilnehmer wohl raus...
...