Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo,

wir möchten in einem mehrsprachigen Projekt verschiedene Serienmails mit Fragebogenlinks zu bestimmten Fragebögen innerhalb des Projekts verschicken. Für Sprachen, die von links nach rechts gelesen werden funktioniert hier alles prima. Allerdings ist eine der Sprachen, in denen die Fragebögen verschickt werden sollen, Hebräisch. Hier scheint es ein Problem mit der Spezifikation des genauen Fragebogens zu geben.

Den Link zum Fragebogen geben wir folgendermaßen an: %link%&q=XXXX&l=heb. Statt des gewünschten Texts wird aber einfach genau "%link%&q=XXXX&l=heb" angezeigt. Ich vermute, dass der Grund hierfür die geänderte Leserichtung ist, allerdings kann ich mir nicht vorstellen, wie man den Platzhalter anders schreiben kann ohne den Link zu zerstören.

Haben Sie hiermit vielleicht Erfahrung?

Danke und beste Grüße!

in SoSci Survey (dt.) by s105330 (320 points)

1 Answer

0 votes

Ich vermute, das betrifft den Link, der unter dem "Zum Fragebogen"-Link noch zusätzlich angezeigt wird, wenn es Schweirigkeiten gibt? Oder haben Sie das Problem im Text-Teil der Mail?

Wenn es um den HTML-Teil geht, suchen Sie im HTML-Code bitte folgenden Abschnitt

<span style="white-space: nobreak; font-family: Courier New, monospaced" class="left-to-right">
%link%</span>

Und ergänzen Sie eine Klasse:

<span style="white-space: nobreak; font-family: Courier New, monospaced" class="left-to-right">

%link%

Und im <style>-Bereich der E-Mail ganz oben ergänzen Sie bitte die Definition für diese Klasse.

<style type="text/css">
    body { margin: 10px; font-family: Verdana, Arial, sans-serif; font-size: 14px; }
    .left-to-right { direction: ltr; unicode-bidi: bidi-override; }
</style>
by SoSci Survey (250k points)
Danke für die schnelle Antwort! Tatsächlich betrifft es allerdings den Text-Teil.

wir haben den Text der E-Mail bei Invitation Mailings --> Mailings --> ID der Mail --> Content (text version) eingegeben. Dort steht für den Link-Platzhalter

%link%&q=INT_01_m1w1&l=heb

Wenn ich allerdings aus der Text-Version die HTML-Version erstelle wird es zu

link%&q=INT_01_m1w1&l=heb%

Und wenn ich dies nun in der HTML-Version korrigiere (sodass es wieder
%link%&q=INT_01_m1w1&l=heb heißt), wird in der E-Mail nur noch link%&q=INT_01_m1w1&l=heb  angezeigt. Irgendetwas scheint also bei der Übersetzung des Textes in die Email schief zu laufen.

Und selbst, wenn der Link bei Nutzung des Text-Editors anscheinend "korrekt" als %link%&q=INT_01_m1w1&l=heb in der E-Mail angezeigt wird fehlt die Verlinkung.

Die von Ihnen genannten Ergänzungen im <style> Bereich habe ich getan; einen <span style> Bereich den ich anpassen könnte gibt es leider gar nicht.

Haben Sie Ideen, wie wir hier weiterkommen? Danke!!
...