Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo:)
Ich habe bereits auf verschiedene Arten versucht meine kombinierten Fragen für die Darstellung auf mobilen Geräten zu optimieren (extra mobil Fragebogen, responsive Darstellung durch Fragetyp "Gerät"..) aber irgendwie funktioniert keine so richtig und die Frage wird noch immer nicht richtig dargestellt. Optimal wäre es auch, wenn die Frage weiterhin in einer Zeile und nicht untereinander angezeigt wird...
Oder habe ich vielleicht alles richtig gemacht, aber die klare Darstellung von kombinierten Fragen mit Grafiken auf Mobilgeräten kann einfach nicht besser funktionieren?

auf dem bild sieht man die darstellung auf der mobilen Alternativversion


auf dem Bild sieht man die Darstellung nach Integration einer Frage zum Gerätetyp


auf dem Bild sieht man den PHP Code


und auf dem bild die dennoch leider noch immer nicht funktionierende mobile Version

edit: hier nun noch der PHP Code, den ich beim Fragebogen-Zusammenstellen eingefügt habe

if (value('A013_ScW') > 500) {
// Kombinierte Frage
  question('A007','combine=A008');
} else {
  // Einzelne Fragen
  question('A007');
  question('A008');
}

was Sie mit den Debug--Informationen meinen ist mir leider nicht ganz klar... hier zb die fehlermeldung, die bei der Fragebogentestung erscheint:
The combined question shows Items with different IDs (1/2, 2/3, 3/4, 4/5) in the same line at position 1, 2, 3, 4. The items in the partial questions are probably sorted differently. If this is not done by intention, it may easily cause misinterpretation of data!

in SoSci Survey (dt.) by s202203 (115 points)
edited by s202203

1 Answer

+1 vote

Kombinierte Fragen sind generell nicht für Mobilgeräte geeignet.

Wenn Sie kombinierte Fragen ermöglichen und (!) Mobilgeräte erlauben möchten, dann müssen Sie mithilfe einer Frage "Gerät und übermittelte Variablen" abfragen, ob es sich um ein Mobilgerät handelt und abhängig davon entweder die kombinierte Frage oder (für Mobilgeräte) eine alternative Darstellung ohne kombinierte Fragen anzeigen.

by SoSci Survey (222k points)
die Frage zum Gerät habe ich bereits in die Umfrage integriert, leider funktioniert es dennoch nicht mit einer vernünftigen Darstellung der kombinierten Frage und auch nicht mit einer alternativen für Mobilgeräte geeigneten Darstellung der kombinierten als "normale" Frage (siehe auch auf dem unteren Screenshot). Was kann ich dann noch tun? Und wie bekomme ich es hin, dass wenigstens die Alternativdarstellung angezeigt wird
Die Frage alleine reicht nicht - Sie müssen auch noch einen PHP-Filter verwenden, damit entweder eine kombinierte Frage angezeigt wird oder die beiden Fragen untereinander.
Danke! aber auch den PHP-Filter habe ich leider bereits eingefügt... dennoch wird bei der mobilen Variante noch immer die kombinierte Frage angezeigt und nicht 2 einzelne. Ich füge in meiner Ursprungsfrage nochmal einen Screenshot ein
Bitte ergänzen Sie in der Frage auch den PHP-Code, den Sie verwendet haben, als Text bzw. Code (mit dem Knopf {}). Im Screenshot ist der Code leider nur schwer zu lesen. Danke.

Ergänzen Sie bitte weiterhin die Debug-Information, welcher auf der Seite angezeigt wird.
Danke für die Antwort!
Der PHP Code ist ergänzt, was sie mit den Debug-Informationen meinen ist mir leider nicht ganz klar... Der Code bei den Entwicklertools? Oder die Warnung auf der Fragebogen Seite bei Testung oder etwas anderes?
> Der PHP Code ist ergänzt, was sie mit den Debug-Informationen meinen ist mir leider nicht ganz klar...

Ich meine die äußert praktische "Debug-Information", den Ihnen SoSci Survey anzeigt: https://www.soscisurvey.de/help/doku.php/de:create:debugging#debug-information

Ihr PHP-Code sieht soweit gut aus. Nur zur Sicherheit: Haben Sie sonst noch andere Inhalte auf der Seite? Spezifisch: Haben Sie die Fragen A007 und A008 zusätzlich auch noch in die Seite gezogen?
[Information]    Interview number 98 is to be continued
[Information]    Questionnaire qnr4 from project test292138 will be used
[Information]    The retention period on page 2 has been additional 6 seconds
[Processing]    Reading answers from page 2
[Information]    Answer missing for A007_01
[Information]    Answer missing for A007_02
[Information]    Answer missing for A007_03
[Information]    Answer missing for A007_04
[Information]    Answer missing for A008_02
[Information]    Answer missing for A008_03
[Information]    Answer missing for A008_04
[Information]    Answer missing for A008_05
[Information]    27% of the questions have been answered so far
[Processing]    Create page 2 in questionnaire qnr4
[Information]    value("A013_ScW") = 1536
[Content]    Create question A007+A008


dies sind die angezeigten Debug Informationen. Und nein, ich habe keine anderen Inhalte bzw. die Fragen A007/A008 auf der Seite.
Die Frage wird an sich ja auch richtig angezeigt, lediglich die Optimierung bzw. Darstellung auf mobilen Endgeräten scheint nicht zu funktionieren
In Ordnung, diese Debug-Information stammt von einem Gerät mit 1536 Platz in der Breite. Und angezeigt wird die kombinierte Frage.

Wenn Sie den Link aus der Browser-Adresszeile nun auf ein Mobilgerät schicken und dort die Seite nochmal mit dem Play-Knopf in der orangen Debug-Zeile neu übermitteln, dann sollte sich die Anzeige am Ende der Debug-Information wie folgt ändern:

[Information]    value("A013_ScW") = 412
[Content]    Create question A007
[Content]    Create question A008

Und statt der kombinierten Frage sollten die beiden Fragen einzeln untereinander erscheinen.
hallo und vielen Dank,
funktioniert leider immer noch nicht. Der Fragebogen öffnete sich einmal auf einem Handy, aber nach einer erneuten Übermittlung hat sich nichts geändert bzw. wurden die Fragen immer noch nebeneinander dargestellt. Habe jetzt noch mehrmals versucht das Ganze zu wiederholen, auch von einem anderen Handy aus, aber jetzt kann ich nicht mal mehr den Fragebogen auf einem Handy über Link öffnen. Es erscheint jetzt bei Öffnen des Links "Ungültiger Link. der übermittelte Schlüssel ist nicht mehr gültig."
> Der Fragebogen öffnete sich einmal auf einem Handy,

Was zeigt die Debug-Information dort nach der erneuten Übermittlung an?

> Es erscheint jetzt bei Öffnen des Links "Ungültiger Link.

Dann haben Sie entweder einen Link mit begrenzter Gültigkeit verwendet (z.B: jenen, den man nach Klick auf den Play-Button unter "Fragebogen zusammenstellen" bekommt) oder das Interview zwischenzeitlich aus dem Datensatz gelöscht.
...