Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Guten Tag,

bei unserem mit PHP programmierten Experiment mit Urnenziehung werden bei Nutzung von Google Chrome bei Items, die über einen Schieberegler abgefragt werden, keine Daten registriert. Mit allen anderen Browsern funktioniert das einwandfrei, lediglich bei Google Chrome sind die Datensätze leer. Woran kann das liegen?

Mit freundlichen Grüßen

in SoSci Survey (dt.) by s168823 (110 points)
edited by s168823
Was genau ist den leer? Nur die Variable zum Schieberegler oder auch andere Variablen? Möchten Sie vielleicht einen Pretest-Link (bitte im Debug-Modus) direkt zu der Seite mit dem Schieberegler posten?
Guten Tag,

danke für die schnelle Antwort! Hier ist der Pretest-Link im Debug-Modus: https://www.soscisurvey.de/gemuese2020/?act=q3bR7sqzw8mdfFqBeeEpBeeE

Genau, lediglich die Variable zum Schieberegler ist leer.

Dankeschön!
Das mit dem Debug-Modus hat schonmal geklappt, danke. Aber könnten Sie bitte einen Link posten, der gleich zur richtigen Seite (oder zur Seite vor dem Schieberegler) führt? Wenn ich nicht immer durch den ganzen Fragebogen klicken muss, geht das Testen deutlich schneller von der Hand.
Natürlich, da haben Sie recht, bitteschön: https://www.soscisurvey.de/gemuese2020/?act=1nIRXAgqsdQ4w8PfubPk9vcI

Das ist jetzt eine Seite bevor das Problem auftritt, da auf dieser Seite die Bedingungen randomisiert zugeordnet werden. Auf der nachfolgenden Seite ist dann das erste Schieberegler-Element, das bei Google Chrome keinen Wert speichert.

Vielen Dank für Ihre schnelle Antwort!
Ich habe den Schieberegler auf der Seite nach dem Pretest-Link getestet und es scheint so, dass auch in Chrome (aktuelle Version unter Windows 10) die Position korrekt in Variabe IS01_01 übertragen wird. Sie haben diesmal den Link ohne Debug-Option erstellt, deshalb kann ich nicht sehen, ob der Wert auch so im Datensatz abgelegt wurde - ich gehe aber stark davon aus.

Wenn Sie möchten, ergänzen Sie auf der nächsten Seite noch folgenden PHP-Code, um den Wert testweise anzuzeigen:

html('<p>Schieberegler: '.value('IS01_01').'</p>');
Guten Tag,

ja tatsächlich, der Wert wurde gespeichert, das sehe ich in den erhobenen Daten. Dann stimmt unsere Vermutung wohl nicht uneingeschränkt, dass es an Google Chrome liegt - oder das Problem tritt nur in manchen Fällen auf? Haben Sie weitere Vermutungen, weshalb es sein kann, dass die Variable des Schiebereglers nicht gespeichert wird? Merkwürdigerweise haben wir bei circa einem Drittel unserer Proband:innen leere Datenpunkte bei den Schieberegler-Items. Auf Nachfrage hin schien es, als hätten genau diese Personen Google Chrome genutzt.
Hier sende ich Ihnen noch einmal einen Link im Debug-Modus, falls Sie einen anderen Lösungsansatz haben, weshalb es sein könnte, dass die Datenpunkte bei einem Teil der Proband:innen nicht gespeichert werden.

https://www.soscisurvey.de/gemuese2020/?act=PxAF1PfpQJZPNCMCIH9sCaw0

Vielen Dank für Ihre Bemühungen und Ihre Geduld!

1 Answer

0 votes

Merkwürdigerweise haben wir bei circa einem Drittel unserer Proband:innen leere Datenpunkte bei den Schieberegler-Items.

Haben Sie überprüft, ob die Seite überhaupt abgefragt wurde (TIME*-Variable)? Vielleicht sind das einfach nur Abbrecher?

Auf Nachfrage hin schien es, als hätten genau diese Personen Google Chrome genutzt.

Nun ja, der Browser hat inzwischen einen Marktanteil von irgendwo bei 60-80%. Das könnte auch Zufall sein.

by SoSci Survey (184k points)
Nein, es sind definitiv keine Abbrecher. Danach folgen weitere Fragebogenitems (Likertskala, nicht mit Schieberegler), die wiederum korrekt registriert werden.
> Nein, es sind definitiv keine Abbrecher.

Die Variable LASTPAGE haben Sie kontrolliert? Und Sie haben auch im Hinterkopf, dass die Abfolge der Variablen im Datensatz i.d.R. nicht der Abfolge im Fragebogen entspricht? Ich frage nur deshalb nach, weil sich ähnliche Fälle bei genauer Prüfung bisher stets durch Abbrecher erklären ließen.

Sind die nicht-befüllten Variablen unter "Erhobene Daten" -> "Daten ansehen" rot, grün oder weiß hinterlegt?
...