Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo liebes SoSci-Team,

leider habe ich ein Problem mit meiner Filterfrage, die mit "Ja" oder "Nein" beantwortet werden soll. Folgendes habe ich bisher eingestellt:

Filterbedingung "Nein"
Filterführung: "Interview beenden/ Screenout" mit dem selbst angelegten Text "S002 Filtertext"

Den Filtertext habe ich unter der selben Rubrik via "Text hinzufügen" erstellt.

Wenn ich den Fragebogen nun im Debug-Modus teste, funktioniert der Filter leider nicht. Die Debug-Info lautet:

[Information] Interview Nummer 219 wird fortgesetzt
[Information] Der Fragebogen base im Projekt madein wird verwendet
[Information] Die Verweildauer auf Seite 1 war 10 Sekunden
[Verarbeitung] Lese Antworten von Seite 1
[Information] Antwort auf S001 = 2
[Information] ▼ Filter S001/1 wird aktiv (Bedingung erfüllt).
[Information] Fragen bisher zu 100% vollständig beantwortet
[Verarbeitung] Erstelle Seite 2 in Fragebogen base
[Inhalt] Zeige Text Vorspann CJ

Muss ich unter "Fragebogen zusammenstellen" eine eigene Seite für den Filtertext einsetzen? Bis jetzt hat es die Funktion des Filters nämlich nicht verändert, ob der Text auf einer Seite steht, oder nicht.

Leider weiß ich nicht, wo das Problem liegt.

Ich freue mich über jegliche Hilfe!

Viele Grüße

in SoSci Survey (dt.) by s140816 (120 points)

1 Answer

0 votes

mit dem selbst angelegten Text "S002 Filtertext"

Haben Sie diesen Text in einer Rubrik angelegt (das wäre korrekt) oder unter "Beschriftungen u. Textbausteine" (was nicht funktionieren würde)?

In S001 haben Sie nur diesen einen Filter, oder? Könnten Sie bitte den genauen Text kopieren, der für den filter angezeigt wird (wenn dieser nicht zum Bearbeiten geöffnet ist)?

Bis jetzt hat es die Funktion des Filters nämlich nicht verändert, ob der Text auf einer Seite steht, oder nicht.

Den Text müssen Sie überhaupt nicht in den Fragebogen setzen, wenn er als Screenout eingestellt ist.

by SoSci Survey (250k points)
Danke für die schnelle Rückmeldung.

Ich bin mir nicht ganz sicher, was mit "Könnten Sie bitte den genauen Text kopieren, der für den filter angezeigt wird (wenn dieser nicht zum Bearbeiten geöffnet ist)?" gemeint ist.

Unter Fragebogen zusammenstellen steht:

 1 aktive(r) Filter
Filter 1
Wenn eine der folgenden Antwortoption(en) ausgewählt wurde: 2
Dann nach dem Klick auf "Weiter" den Text ∅ anzeigen und das Interview beenden

Den dazugehörigen Text habe ich in einer Rubrik angelegt.
> Dann nach dem Klick auf "Weiter" den Text ∅ anzeigen und das Interview beenden

Das "Leere Menge" Zeichen steht dafür, dass Sie im Filter keinen Screenout-Text ausgewählt haben. Bitte prüfen Sie das im Filter nochmal. Und wie gesagt: Nur Texte, die in einer Rubrik angelegt wurden, können dort ausgewählt werden.
> Das "Leere Menge" Zeichen steht dafür, dass Sie im Filter keinen Screenout-Text ausgewählt haben.

Danke für den Hinweis.

Nach dem ich die Filterfrage und den Text noch mal neu erstellt habe, funktioniert der Filter.

Worin das Problem bestand, weiß ich nicht. Der Text war von Beginn an in einer Rubrik angelegt. Hauptsache es klappt nun :)
...