Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo!

Ich möchte einen Feedbackbericht am Ende des Fragebogens erstellen. Hierzu habe ich:

  • einen Einleitung-Textbaustein (Fedbackreport Einleitung)
  • einen PHP-Code, der mit einem Textbaustein (resultsTC) verknüpft ist => Ergebnisse des Teilnehmers
  • einen abschließenden Textbaustein (Feedbackbericht Ende)

Dies soll in der aufgelisteten Reihenfolge erscheinen. Dazu habe ich in einem PHP-Code auf der vorletzten Seite des Fragebogens folgendes programmiert:

text('Fedbackreport Einleitung');
text('resultsTC', array(
'%val-TC01%' => valueMean('TC01'),
));
text('Feedbackbericht Ende');

Doch dennoch erscheint es im Fragebogen in folgender Reihenfolge:
- Einleitung-Textbaustein (Fedbackreport Einleitung)
- abschließender Textbaustein (Feedbackbericht Ende)
- PHP-Code der mit Textbaustein resultsTC verknüpft ist, also die Ergebnisse des Teilnehmers

Was kann ich tun um meine gewünschte Reihenfolge zu bekommen?
Könnte es sein, dass es etwas damit zu tun hat, in welcher Reihenfolge ich die Textbausteine angelegt und gespeichert hatte?

Vielen Dank für Ihre Hilfe!
Liebe Grüße.

in SoSci Survey (dt.) by s087869 (160 points)

1 Answer

0 votes

Ich tippe auf zwei wahrscheinliche Ursachen für die falsche Anzeige.

  1. Haben Sie die Textbausteine evtl. zusätzlich noch in den Fragebogen "gezogen"? Wenn ja, dann ziehen Sie sie wieder hinaus, das text() reicht.

  2. Haben die Textbausteine eine valide HTML-Struktur? Vor allem wenn Sie mit Tabellen arbeiten ist das Risiko groß, dass die Reihenfolge bei der Anzeige im Browser durcheinander kommt.

by SoSci Survey (84.7k points)
1. Hatte ich erst, habe ich dann aber wieder entfernt. Das sollte nicht das Problem sein.

2. Sie waren auf "Formatierter Text" eingestellt. Ich habe es nun auf "HTML-Code" umgestellt. Tabellen habe ich nicht verwendet, aber viele eingerückte Passagen. Könnte das ein Problem darstellen?

Es funktioniert nämlich leider dennoch nicht.
Sie können gerne einmal einen Pretest-Link posten, dann kann ich mir das genauer ansehen.
Ich habe den Fragebogen schon freigegeben, um selbst einiges zu testen. Ich habe den Link aber noch nicht veröffentlicht, sodass keine Daten von Personen anfallen können, bevor der Fragebogen richtig fertig ist.
Wenn ich den Link hier poste wäre er quasi öffentlich. Wenn ich das richtig sehe, kann ich unter "Erhobene Daten" --> "Alle Daten löschen" alle angefallenen Daten (aber nicht den Fragebogen selbst?) löschen, bevor mein Fragebogen in die richtige Testphase geht. Richtig? Wenn das so stimmt, dann würde ich ihn hier posten, ansonsten leider eher ungern.
Sie können unter "Befragungsprojekt" Pretest-Link erstellen, die keine "richtigen" Daten verursachen. Aber prinzipell könnte man sich daraus den korrekten Link erschließen, ja.

Sie können vor dem Start alle Daten löschen oder bei der "Auswahl gültiger Fälle" einfach alle Daten ausschließen, die vor einem best. Datum angefallen sind.
...