0 votes
in SoSci Survey (dt.) by s084678 (145 points)

Hallo,

Ich versuche gerade ein Video mittels iframe-Tag einzubinden, bekomme aber dabei folgende Fehlermeldung:

Warnung: Der HTML-Code des Textbausteins TT05 [ger] scheint nicht
valide zu sein. Bitte überprüfen Sie den HTML-Code, um Probleme mit
der HTML-Struktur des Fragebogens zu vermeiden. Intern wurde folgende
Fehlermeldung ermittelt: [line 1] htmlParseEntityRef: expecting ';'

Den Code den ich zum einbetten genutzt habe ist folgender:

<iframe src="https://videoakademie.ko-ld.de/Panopto/Embed.aspx?id=fcd186dd-eac6-40ca-8430-ac0000bc5640&v=1" width = "800" height = "600" style="padding: 0px; border: 1px solid
#464646;" frameborder="0" allow="autoplay"></iframe>

Habe ich etwas vergessen? Einen Befehl, ein Komma, ein Attribut?

Liebe Grüße

1 Answer

0 votes
by SoSci Survey (309k points)

Die Fehlermeldung beschwert sich über das kaufmännische Und (&) im Link.

Das ist zwar korrekt, aber das Und-Zeichen hat in HTML eine besondere Bedeutung. Daher gehört es als HTML-Entität &amp; geschrieben:

<iframe src="https://videoakademie.ko-ld.de/Panopto/Embed.aspx?id=fcd186dd-eac6-40ca-8430-ac0000bc5640&amp;v=1" width = "800" height = "600" style="padding: 0px; border: 1px solid #464646;" frameborder="0" allow="autoplay"></iframe>

In Ihrem Fall würde es wohl auch so funktionieren, denn jeder Browser bemerkt, dass &v keine gültige HTML-Enzität ist. Aber ganz korrekt ist es eben nicht.

by s084678 (145 points)
Danke! Perfekt!

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...