Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Wir haben grade unseren Fragebogen zum Testen an eine blinde Person gegeben. Er hatte dabei folgende Rückmeldung:

„Der Fragebogen ist eigentlich barrierefrei. Mit JAWS gibt es
allerdings ab Frage 4 das Phänomen, dass jede Abfrage scheinbar
doppelt vorhanden ist, also in zwei Zeilen unter einander.

Wie hier: Information zu Farben Information zu Farben

Eventuell ist da im code ein überflüssiger Umbruch gesetzt, weswegen
JAWS so reagiert. Mit NVDA gibt es das Problem aber nicht.“

Bei den genannten Fragen handel es sich um Skalen-Fragen (Zwischenwerte beschriftet)

Jetzt bin ich leider kein Programmierspezialist, deshalb wollte ich fragen, ob es zu dem oben benannten Problem eine "einfache" Lösung zur Behebung gibt. Es ist sehr wichtig, dass unser Fragebogen möglichst barrierefrei ist.

in SoSci Survey (dt.) by s137868 (345 points)
JAWS wird ja reecht häufig eingesetzt. Das geschilderte Problem kam mir so bisher noch nicht unter.

Könnten Sie wohl bitte einmal zurückfragen, was genau doppelt vorgelesen wird? Nur der Itemtext oder auch die Antwortoptionen? Falls Sie nicht im barrierefreien Modus starten (nicht empfohlen außer wenn Sie ausschließlich Personen mit Sehbehinderung befragen), könnten Sie bitte weiterhin fragen, ob der Befragte den Fragebogen in den barrierefreien Modus umgeschaltet hat?

Und könnten Sie weiterhin noch einen Pretest-Link direkt (!) zur betroffenen Seite posten, damit ich mit die spezifische Frage einmal ansehen kann?
Hallo,

Ich werde die Rückfrage an den Tester schicken und melde mich dann. Eingestellt ist, dass der Fragebogen automatisch im Screenreader-Modus startet.

Hier der direkte Pretest-Link zur betroffenen Seite. https://s2survey.net/Bilddigital/index.php?i=LCMSCD4O3SEV&rnd=RHDP
Laut dem Tester ist das ab hier das Problem.
Wenn ich die Seite aufrufe und in den Quelltext sehe, sieht alles korrekt aus. Warten wir mal ab, was der Tester Genaueres berichtet.
Hier die Antwortmail des Testers:

Hallo ,

Wenn man mit dem Cursor abwärts geht, liest die Sprachausgabe den Label-Tag zwei mal vor, so als stünde der Text in zwei Zeilen unter einander. Mit JAWS wird erst beim dritten Mal das Dropdownmenü angesagt. Mit VoiceOver in Safari gib es auch diese scheinbaren zwei Zeilen und VO sagt bei beiden „Einblendmenü“ an.

 

Ich habe mal in den Quelltext geguckt und vermute es liegt daran, dass Label-Tag und Select-Tag im gleichen List Item untergebracht sind. Ob das mit einem einfachen <br> zu lösen ist, weiß ich nicht.

Übrigens sagt JAWS zwar die Liste an, nicht aber die List Items, wahrscheinlich ebenfalls wegen der verschachtelten Tags.

 

Wenn man die Optionen mit Tab durchläuft, klappt ab Frage 4 alles wie vorgesehen. Bei den Fragen 2-3 würde man dann aber die Fragen und alle Antwortmöglichkeiten außer der jeweils Ersten überspringen. Daher nutze ich Tab bei so etwas generell nicht.
Puh. Schwierig. Könnten Sie nochmal einen aktuellen Pretest-Link posten oder uns die betroffenen Frage als XML-Datei exportieren und an info@soscisurvey.de senden? Dann versuchen wir, ein Testsystem mit JAWS aufzusetzen und das Problem zu replizieren.
Erstmal vielen Dank, dass SIe so schnell und engagiert an dem Problem arbeiten.

Hier ein aktueller Pretest-Link: https://s2survey.net/Bilddigital/?act=HB3mVyqPVDx8iSmNNRUuyTk6

Eine Frage dazu: Wir werden ab morgen eine Probe-Auswertung machen und werden dazu den Original-Fragebogen öffnen. Ist das ein Problem, wenn gleichzeitig ein Pretest von Ihnen bearbeitet wird?
Nein, das ist unproblematisch. Ich habe nochmal in den HTML-Code gesehen und finde nach wie vor nichts, was das Problem erklärt. Ich würde auch nicht ausschließen, dass es sich um ein Problem in der aktuellen Programmversion von JAWS handelt ... aber das werden wir uns nochmal genauer ansehen.

Ich habe Seite 4 mit HT03 jetzt auch nochmal heruntergeladen, damit ich das ohne Aufruf Ihres Fragebogens testen kann.

Eine Überlegung noch: Der Teilnehmer hatte den Fragebogen im Pretest-Modus ausgefüllt, oder? Wenn der Fragebogen ohnehin jetzt dann online geht: Könnten Sie nachfragen, ob der JAWS-Fehler auch im regulären Fragebogen auftritt? Ich denke zwar nicht, dass die Frage-Markierungen aus dem Pretest-Modus Probleme bereiten, aber ich kann es auch nicht 100%ig ausschließen.
Hallo. Nein der Testende hat die Testung im regulären Modus gemacht. Wir werden morgen für eine Woche einen weiteren Pretest mit mehreren Teilnehmenden durchführen, der ebenfalls im regulären Modus stattfinden wird (es wurde gewünscht, auf den Pretest-modus zu verzichten, wegen der Anmerkungsfelder auf jeder Seite usw.)
Könnten Sie noch herausfinden, in welchem Browser der Tester mit JAWS gearbeitet hat? Danke.
Das Problem tritt mit JAWS in Firefox und mit VoiceOver in Safari auf. Mit
JAWS und IE tritt es nicht auf.

Please log in or register to answer this question.

...