Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo noch einmal,

eigentlich lief alles und mein Pretest ist auch fast beendet. Allerdings sagt es mir nun plötzlich:

Die Variable VU16 gibt es in diesem Projekt nicht (siehe Variablen-Übersicht). Daher kann kein Antwort-Wert dafür ermittelt werden.

Die Frage VU16 wird allerdings exakt zuvor abgefragt und dahinter liegt dann nur ein Code, der feststellen soll, ob die Frage beantwortet wurde und sie rot markiert, falls nicht.

Hier ist der Link zur entsprechenden Seite:

https://www.soscisurvey.de/versicherungsentscheidungen2019/?act=fOfLgOx1Vq2GsTB8KFHBK6oX

Was habe ich dieses Mal falsch gemacht :(

in SoSci Survey (dt.) by s120134 (180 points)
Könnten Sie vielleicht noch einen Link zu der Seite mit der Frage VU16 posten? Danke.
Ergänzen Sie gerne auch den Abschnitt zu SE08 aus der "Variablen-Übersicht".
Das ist die entsprechende Seite. Beantworten Sie einfach alles mit Ja, dann blendet es VU16 ein.

Einen Abschnitt SE08 gibt es bei mir nicht. Nur die Rubriken EM, ZU, VU, SD und EL und die entsprechenden Zahlen für die Fragen.

1 Answer

0 votes

Danke für die Erklärung zu den ausgeblendeten Fragen :)

Soweit ich sehe, verwenden Sie für die Frage VU16 den Fragetyp "hierarchische Auswahl" mit Mehrfachauswahl. Dort gibt es eine Variable für die ANzahl der gewählten Optionen (VU16_CN) und dann jeweils eine Variable pro Auswahloption (VU16x01, VU16x02, ...).

Wir haben mit einem kürzlich erfolgten Update die Funktion verfeinert, um Variablen in der value()-Funktion zu identifizieren. In diesem Zuge wurde auch eine Fehlfunktion entfernt, welche bei Verwendung einer falschen Variable (in Ihrem Fall VU16, die es so im Projekt nicht gibt und auch vor dem Update nicht gab, s. Variablen-Übersicht) fälschlicherweise auf eine andere Variable (in Ihrem Fall "VU16_CN") verwiesen hatte.

Im Fall von "einfachen" Items haben wir mittlerweile eine Erkennung von z.B. "AB01_1" als "AB01_01" wieder ergänzt, damit laufende Erhebungen nicht gestört werden. Aber in Ihrem Fall würde ich Sie einfach bitten, die korrekte Variable im Filter zu verwenden. Wenn Sie die Anzahl der gewählten Optionen haben möchten, wäre das "VU16_CN".

by SoSci Survey (129k points)
Hallo!
Ich habe das gleiche Problem, Pretest erfolgreich absolviert und dann eigentlich nichts mehr an der Struktur geändert. Nun wird mir bei einer Frage, die absolut problemlos ist (kein Filter, einfaches Dropdown-Menü) die Fehlermeldung "Variable TO_01 is unknown to this project (see listing of variables). Therefore no result can be retrieved." angezeigt.Hängt das auch mit dem Update zusammen? Und was muss ich ändern, damit die Frage wieder funktioniert?
Über eine kurzfristige Antwort wäre ich sehr dankbar, eigentlich sollte heute meine Feldphase starten...
...