Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo,

With reference to my previous post(Link) I have attached the below screen shots. .

$deck = value('G101');
$i = loopPage(10);
html('<p>'.$deck.'</p>');
$textID = 'EmployeeInfo'.$deck.sprintf('%03d', $i + 1);
$qID = 'G1'.sprintf('%02d', $i + 2);
// Display question and text - like before
$data = dbGet($textID);
$text = $data[0];
html('<p>'.$text.'</p>');
question($qID);

The questionnaire:

q1

Variables Listing: only few, the code continues till 'G111'

v1

The Answered questionnaire:

The first question in the questionnaire: Same text, question is repeated all 10 times. You can see the answer is not recorded. Only the 10th question the answer is recorded.

q1

10th Question:

q2

Thank you

closed with the note: Received no more information on this question (see comment)
in SoSci Survey (English) by s075828 (290 points)
closed by SoSci Survey
According to the variable listing, the questions G102 and G103 seem identically? When you run the questionnaire in debugging mode, what are the question IDs displayed next to the questions? Are the answers stored in debugging mode? What happens if you allow for a "back" button the the questionnaire settings?

Is there any error message displayed when you save the texts "EmployeeInfo..."?
Sorry for the late reply.

According to the variable listing, the questions G102 and G103 seem identically?

>> Yes, I just repeated it for testing purpose.

When you run the questionnaire in debugging mode, what are the question IDs displayed next to the questions?

>> They are displayed from G102 till G111, so i guess the questions are getting picked properly in order.

Are the answers stored in debugging mode?

>>If you mean in the View Data Set, then yes the answers are getting stored with debug mode.

What happens if you allow for a "back" button the the questionnaire settings?

>> The result is same. Only the 10th question has an answer and rest all are repeated.
The debugging mode works alike the normal interview mode. So, if it works in debugging, but not in normal mode, than it's something else. Could you please check if you maybe have two questionnaire (left in the navigation or in the tab "further questionnaire" when you select "compose questionnaire")?

Regarding the back button my question is: Does the questionnaire remember the previous answer if you use the back button? What do you mean by "repeated"? Is the previous answer preset or is it a blank question shown on every page?
Could you please check if you maybe have two questionnaire (left in the navigation or in the tab "further questionnaire" when you select "compose questionnaire")?

>> Yes, I have two questionnaires but the other questionnaire has nothing inside.

Does the questionnaire remember the previous answer if you use the back button?

>> Yes when I emailed the questionnaire and checked it the back button did remember the answer i previously selected.

What do you mean by "repeated"? Is the previous answer preset or is it a blank question shown on every page?

>> Ok I got like 10 vignettes imported using Database for contents. It has below structure:

Entries in Database:

Key :    EmployeeInfo3001   

language:  eng   

0:             A Woman you observe your supervisor who has gained only few experience with secure IT usage covering her/his laptop camera and microphone with a piece of tape. If the wrong person accessed sensitive corporate data on third-party cloud servers, it could compromise the security and privacy of this data. If management learned that your {…} did that behavior, it is very likely that s/he would be formally sanctioned (punished) in a swift, severe, and certain way. Your {…} joined the company a long time ago and has a perfect record when it comes to conformity with organizational rules and procedures.
.
.
.
and followed by subsequent vignettes with different texts.

Now in the questionnaire when i use this, everything is working fine. Fine in the sense, it picks in below order:

EmployeeInfo3001 G102
EmployeeInfo3002 G103
.
.
.
EmployeeInfo3010 G111

Even in view data set it stores the right answers. The back button is also working properly as per your question.

The problem is when i preview the Questionnaire from a particular respondent it displays the vignettes from EmployeeInfo3001 is getting repeated for all the 10 pages and the question G102 is also getting repeated from page 1 to 10. Only difference is in the 10th page the answer is shown (as shown in above picture).

I am not sure but could it be because i use only one page and repeat it so many times ? I see in the above picture Page 01 02 shown for all the 10 pages.
If I understand your question correctly, the data is collected as it should (can be seen in "view data"), but the print view ("when i preview the Questionnaire") of a record is incorrect. Is this what is wrong?
Yes. The print view is not showing properly.
Okay, then we're getting closer. Yes, after testing this, I can confirm that loopPage() currently does not work in the print view. I'll add this as a bug to be repaired, however, I cannot tell when it will be fixed. Is this bug critical to your work or was it just an irritation so far?
Okay, thanks for the information. It is not important but would be great if the user is able to see the result in the preview. I also wanted to know if I was doing something wrong with the process.
...