0 votes
in SoSci Survey (dt.) by s269381 (120 points)

Guten Tag,

bei folgendem Fragebogen funktioniert der Redirect zu Sona-Systems nicht richtig:
https://www.soscisurvey.de/accul-IC/

Wenn ich von Sona Systems mit einer Reference im Fragebogen lande, also dann z.B. mit der URL
https://www.soscisurvey.de/accul-IC/?r=123
dann komme ich zunächst zur Sprachauswahl. Dann nimmt der Fragebogen den r-Code in der URL noch mit. Aber wenn ich auf der Seite darauf noch einmal auf "weiter" gehe, dann verschwindet r=123 aus der URL. Daher vermute ich, dass das der Grund ist, warum der Redirect am Ende nicht funktioniert. Ich finde im Fragebogen in SoSci aber leider nicht den Fehler bzw. wie ich das beheben könnte.

Über Hilfestellung wäre ich sehr glücklich.

Beste Grüße

1 Answer

0 votes
by SoSci Survey (316k points)

Aber wenn ich auf der Seite darauf noch einmal auf "weiter" gehe, dann verschwindet r=123 aus der URL.

Das ist korrekt und soll auch so sein. Der Code sollte aber als Variable REF im Datensatz hinterlegt sein. Falls nicht, haben Sie in den Projekt-Einstellungen unter "Spezielles" womöglich eingestellt, dass der Parameter nicht "r" heißen soll.

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...