Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

I am using php code to set the page order for the second half of my survey. On these pages, when a missing response is probed, selecting 'I do not want to answer' and clicking 'Next' doesn't progress the study to the next page. Instead, it reloads the same page (keeping any responses that were previously entered). Then if you click the 'Next' button at the bottom of the page, it will progress to the next page. Is there anything that can be done about this (aside from not probing for missing answers on these pages)? Many thanks!

in SoSci Survey (English) by s057462 (330 points)

1 Answer

0 votes

This is a known bug that occurs when pages are skipped during the page order. For example pages that only contain PHP code, but no contents.

Using goToPage('next') on them or avoiding non-content pages at all should solve the issue.

It will not be before summer 2022 that non-content pages in the constellation that you describe will work as expected. This requires substantial changes in the software.

by SoSci Survey (198k points)
Is there any way to solve the issue if the pages do contain content? For my study, some participants need to complete pages 16, 17, 18, 20...etc., whereas other participants need to complete pages 19, 17, 18, 20... etc.

All these pages have content. But because I'm setting the page order on page 15 (using setPageOrder code), the error I mentioned above happens if there are missing responses on any page after page 15.  

If I go directly to page 16 (skipping the setPageOrder code), this error doesn't happen.
> All these pages have content.

Do they "only have" content or do they also show content, each? The critical point is when a page automatically skips to the next, because it does not show any (visible) contents. You can see that in the debug information when two pages appear to be displayed.
They all show visible content (each page is a questionnaire).
If you like, I will create an admin access login for this project, and take a look myself. If you want that, please tell me the name of the questionnaire and wehere I have to click to reproduce the issue.
That would be great, thank you. The name of the project is SexualArousalAndDecisionMaking. The name of the questionnaire is Main Study.

Start on page 14 (the answer to this question is used on page 15 to randomize people to one of the two page orders). Then on the next page that appears, submit the page with some answers missing. When prompted about the missing responses, select 'I do not want to answer' then 'Next'. This gets rid of the missing answer prompt, but doesn't progress to the next page unless you go to the bottom of the page and click 'Next' again.

This error doesn't happen unless you start on page 14 (or earlier), so it seems to have something to do with the setPageOrder code being used on page 15.
Thanks for granting access. Okay, the debug information after answering page 14 says:

> No visible content on this page, continue with page 16

That is the cause of the issue that you encounter.

Please try placing an explicit goToPage('next') below the setPageOrder(). I'm not sure that helps, but it's worth a try. If it does not help, please use a goToPage() on that page and place the setPageOrder() on the next page.
The latter solution worked. Thank you so much for your help.
...