Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Hallo sehr geehrtes Soscisurvey-Team,

ich möchte demnächst mit meiner Erhebung starten und bin gerade mit dem Techniktest beschäftigt, wo ich zwei Probleme entdeckt habe:

  1. Wenn eine Angabe fehlt, zeigt mir Soscisurvey bei meinen Daten rot hinterlegt korrekt an, dass es sich hier um einen fehlenden Wert handelt. Wenn ich mir die Daten in Excel ansehe, ist das Kästchen jedoch einfach leer, anstatt dass -9 dort steht, wie es eigentlich sein sollte. Laut Variablenansicht ist ganz normal -9 für "nicht beantwortet" festgelegt.

  2. Ich kann das Excel-File in SPSS nicht öffnen. Andere Files funktionieren ganz normal, aber wenn ich meine Daten als Excel herunterlade und dann in SPSS öffnen möchte, bekomme ich eine Fehlermeldung ("Fehler. Befehlsname: GET DATA. Fehler beim Lesen der Informationen für das Arbeitsblatt.").

Ich habe leider in den Fragen keine ähnlichen Probleme bzw. Lösungen gefunden, aber ich hoffe sehr, dass Sie mir weiterhelfen können.

Vielen Dank schon einmal!

in Datenauswertung by s185964 (120 points)

1 Answer

0 votes

ad 1) Was haben Sie denn beim Excel-Download eingestellt für "Fehlende Werte"?

ad 2) Sie sollen das Excel-File auch nicht in SPSS öffnen - dabei würden Sie alle Variablen- und Wertelabels verlieren, verwenden Sie stattdessen den SPSS-Export: Datenimport in SPSS (komfortabel)

by SoSci Survey (194k points)
1) ich dachte ich hätte das auf "Standard (-1, -9) festgelegt, habe jetzt noch einmal darauf geachtet und es erneut downgeloaded, und jetzt wird mir das Fehlende als -9 angezeigt, vielen Dank!

2) Das habe ich jetzt versucht, aber da bekomme ich dieselbe Fehlermeldung: "Fehler. GET DATA (2063) Fehler beim Lesen der Information für das Arbeitsblatt." Der Download als CSV hat funktioniert, dann werde ich das in Zukunft so machen. Es verunsichert mich nur ein wenig, dass irgendwas mit meiner Exceldatei schon jetzt beim technischen Funktionstest nicht klappt.
> Es verunsichert mich nur ein wenig, dass irgendwas mit meiner Exceldatei schon jetzt beim technischen Funktionstest nicht klappt.

Aber nochmal: Die Download für Excel (XLSX) und SPSS (SPS) haben nichts (!) miteinander zu tun. Für den SPSS-Import sollten Sie ausschließlich die SPS-Datei benötigen - und wenn Sie diese ausführen, dann sollte da auch kein Fehler auftauchen.

Es ist absolut sinnvoll, das bereits im technsichen Funktionstest zu klären und jetzt auch nochmal zu prüfen. Wenn Sie mit der Erhebung durch sind, haben Sie keine Zeit für solche Lästigkeiten.
...