Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Ich möchte von meinen Proband:innen insgesamt fast 300 Bilder bewerten lassen. Damit aber nicht jeder:jede 300 Bilder bewerten muss, habe ich diese in Sets aufgeteilt, von denen jede:r Proband:in nur eines bekommt.

Dafür habe ich folgenden PHP-Code eingefügt:

$zahl = random(1, 21); // Insgesamt gibt es 21 Bild Sets.
if ($zahl == 1) {
    $questions = getQuestions('O1'); //O1 ist ein Bild-Set (Rubrik)
    foreach ($questions as $qID) {
        question($qID);
    }

Jedes Item der Rubrik O1 besteht aus drei Sub-Fragen mit offener Texteingabe und als "Hauptfrage" habe ich mit html ein Bild eingefügt:

<img src="pro://Bildname.jpg" alt="Bild XY" width="400px">

In der Vorschau im Fragenkatalog wird alles wie gewollt dargestellt, auch im Debug-Modus funktioniert alles und ich bekomme keine Fehlermeldung. Verschicke ich aber einen Pretest oder teste den Fragebogen selbst als Ganzes und nicht nur die eine Seite, werden zwar die drei Subfragen angezeigt, aber nicht die Bilder (Hauptfrage). Auch der Platzhaltertext (alt=BildXY) wird nicht angezeigt.

Ich habe auch versucht die Bild-Sets folgendermaßen aufzurufen:

} elseif ($zahl == 2){
  show(question('O202'));
  show(question('O207'));
  show(question('O206'));
  show(question('O205'));
  show(question('O208'));
  show(question('O209'));
  show(question('O210'));
  show(question('O211'));
  show(question('O212'));
  show(question('O213'));
  show(question('O214'));
  show(question('O215'));
  show(question('O216'));
  show(question('O217'));
} 

Warum werden die Bilder nicht angezeigt?

closed with the note: hat sich gelöst das Problem
in SoSci Survey (dt.) by s167782 (125 points)
closed by s167782
...