Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Guten Tag,

in meinem Fragebogen werden fast ganz zum Schluss Kontrollfragen abgefragt (z.B. ob die Bilder in der Studie alle richtig dargestellt wurden). Diese Fragen kann man mit "ja" oder "nein" beantworten, wobei hinter "nein" ein Textfeld ist. Da beide Fragen Pflichtfragen sind, auf die ein Teilnehmer eine Antwort geben muss, muss bei der Antwort "nein" auch das Textfeld ausgefüllt werden - bzw. es muss zumindest ein Buchstabe hinein getippt werden.
Wird "nein" angeklickt und nichts geschrieben, dann bekommt der Teilnehmer beim Klicken auf "weiter" um zur letzten Seite des Fragebogens zu kommen, eine entsprechende Fehlermeldung. Wird dann eine Eingabe gemacht (oder die Antwort zu "ja" verändert), so erscheint die Fehlermeldung nicht mehr, aber die Seite wird ein zweites Mal geladen. D.h. der Teilnehmer muss noch einmal auf "weiter" klicken um zur letzten Fragebogenseite zu kommen. Dieses Problem tritt bei anderen Pflichtfragen nicht auf. Da wird nach einer Korrektur/ Beantwortung der entsprechenden Fragen direkt die nächste Seite geladen.
Ich befürchte, dass das die Teilnehmer verwirren könnte und würde gerne wissen ob es für dieses Problem eine Lösung gibt.

Angehängt sind zwei Pretest-Links (einen direkt zur entsprechenden Seite - aber dann tritt das Problem nicht auf) und einen von Anfang an des Fragebogens, falls Sie das selbst einmal testen wollen.

Link zur entsprechenden Seite:
https://www.soscisurvey.de/test196703/?act=SalSeOQ4d4pARTyVnx9DJqBN

Link zu Seite 1:
https://www.soscisurvey.de/test196703/?act=qvkgC65LLcWegRkwCHHdL7Hx
(jeder Link zu einer anderen Seite würde Fehler produzieren, weil einige Variablen dann nicht geladen wurden aber abgefragt werden)

Auf der entsprechenden fragebogenseite befinden sich zudem nur die Elemente, die man auch sieht und kein PHP-Code etc.

Liebe Grüße und vielen Dank im Voraus!

in SoSci Survey (dt.) by s137634 (640 points)
Könnten Sie noch einen (Pretest-)Link erstellen, bei welchem auch die Debug-Informationen angzezeigt werden? Dann kann ich mir das gerne genauer ansehen.

Tritt das Problem auf, wenn Sie den Pretest-Link eine Seite vor der Problem-Seite starten lassen?
Vielen Dank für Ihre schnelle Antwort!

Hier zwei neue Links:
Ab Seite 1:
https://www.soscisurvey.de/test196703/?act=O2bYIHz71qIIZhb66qEHH3FL

und ab der entsprechenden Seite:
https://www.soscisurvey.de/test196703/?act=QjcUnIWy5TbUHOwoptxjBZqg

Wenn ich den Fragebogen eine Seite vorher starte dann tritt das Problem nicht auf.

1 Answer

0 votes

Danke für den Link. Soweit ich beurteilen kann, besteht das Problem aus einer Kombination von vielen leeren Seiten, sodass die Abschlussfragen eigentlich (nicht sichtbar) gemeinsam mit vielen anderen Seiten angezeigt werden

[Verarbeitung]	Lese Antworten von Seite 48+49+50+51+52+53

und der Seitenabfolge, die dort hinten offenbar noch aktiv ist:

[Information]	Entsprechend der vorher festgelegten Seitenabfolge wird Seite 49 [Strings] angezeigt
[Verarbeitung]	Erstelle Seite 49 in Fragebogen A_Videolaenge26112021
...
[Information]	Die Seite zeigt keine Inhalte, automatisch weiter mit Seite Nr. 52
[Verarbeitung]	Erstelle Seite 52 in Fragebogen A_Videolaenge26112021
...

Die Seitenabfolge hat in der aktuellen Version von SoSci Survey leider noch ein paar Probleme mit leeren Seite, die autoamtisch übersprungen werden. Ich gehe stark davon aus (a) dass das im vorliegenden Fall die Wiederholung verursacht und (b) dass Sie die Wiederholung los sind, wenn Sie die leeren Seiten entfernen.

Je nachdem, was auf den leeren Seite an Inhalten ist, können Sie diese (z.B. PHP-Code für die Auswertung) vielleicht einfach auf die Seite mit dem Inhalt packen.

by SoSci Survey (154k points)
Vielen Dank für Ihre schnelle Antwort!

tatsächlich befinden sich davor ein paar leere Seiten. Das Problem ist hier, dass ich den PHP-Code von diesen ungerne auf eine Seite mit Inhalt schieben würde. Das oben beschriebene Problem tritt erst auf seitdem ich die Fragen auf eine Extraseite geschoben habe. Als sie noch mit dem Code auf einer Seite waren gab es nämlich das Problem, dass dieser bei einer fehlenden Antwort quasi zwei Mal geladen wurde. Wenn man keinen Text eingegeben und dann auf "weiter" geklickt hat erschien eine Fehlermeldung, die Probleme im Code auswies. Zudem wurden die interne Variablen, für die der Code im Hintergrund existierte, dann falsch berechnet und gespeichert. Da es eigentlich auf jeder Seite Fragen gibt die zwingend beantwortet werden müssen und die Hintergrundberechnungen nur am Ende der Studie passieren können, weil dann alle Variablen von den vorherigen Seiten vorliegen, ist diese Lösung für mich leider nicht wirklich umzusetzen.
Würde es noch eine andere geben?

(Es wäre ggf. noch möglich den Code auf die letzte Seite mit der Aufklärung zu bewegen. Hier besteht aber die Gefahr, dass Probanden nicht bis zu dieser klicken und dann viele wichtige Informationen verloren gehen würde. Deswegen schrecke ich auch davon zurück. Ich werde es intern aber ansprechen.)
> Als sie noch mit dem Code auf einer Seite waren gab es nämlich das Problem, dass dieser bei einer fehlenden Antwort quasi zwei Mal geladen wurde.

Das Problem haben Sie m.E. jetzt auch - denn die leeren Seiten werden aufgrund der fehlenden Antwort auch wiederholt ausgeführt.

> Wenn man keinen Text eingegeben und dann auf "weiter" geklickt hat erschien eine Fehlermeldung, die Probleme im Code auswies.

Dann sollten die Probleme mit dem Code behoben werden.

>  Zudem wurden die interne Variablen, für die der Code im Hintergrund existierte, dann falsch berechnet und gespeichert.

Auch das deutet eher auf Fehler im Code hin ... und sollte behoben werden, denn wenn Sie nicht wissen, woher der Fehler kam, dann kann das in Ihrer Erhebung auftreten ohne dass Sie es bemerken.

> Würde es noch eine andere geben?

(A) Bauen Sie noch eine andere Seite mit Inhalt vor die Seite mit der letzten Frage.

(B) Warten Sie bis Q2/2021, bis (hoffentlich) die neue Version mit geänderter Verwaltung von Seitenabfolgen erscheint.

Aber wie gesagt: Wenn der Code herumzickt, dann sollten Sie die Probleme beheben, statt diese mit einer vermeintlichen Lösung zu verschleiern.
Ich bin ehrlich gesagt etwas verwirrt. Die Fehlermeldung zum Code trat nur dann auf, wenn die Frage mit "nein" beantwortet, kein Text eingegeben und auf "weiter" geklickt wurde und sonst nicht. Seitdem der Code auf einer separaten Seite ist passiert das nicht mehr. Zudem haben wir viele Datensätze erstellt und abgeglichen und es traten nur dann Probleme auf, wenn man den oberen Fehler produziert hat. Der Fehler bezog sich auf einen Teil des Codes, der auf die in einem Array gespeicherte, mit shuffle() ausgewürfelten Reihenfolge der Seiten zugriff um die Fragen, die auf den jeweiligen Seiten mit "ja" beantwortet wurden,  für weitere Auswertungen in ihrer Reihenfolge eine interne Variable zu speichern.
Da diese Fehlermeldung nun ausbleibt würde ich davon ausgehen, dass das Problem nicht mehr auftritt. Bzw. dass bei mehrfachem laden vielleicht etwas durcheinander geraten ist. Oder besteht die Gefahr dennoch?

Vielen Dank für die anderen Lösungsvorschläge! Ich werde prüfen ob wir eine weitere Seite mit Inhalt einbauen können.
> Da diese Fehlermeldung nun ausbleibt würde ich davon ausgehen, dass das Problem nicht mehr auftritt.

Schwer zu sagen, vermutlich ist irgend etwas besser geworden als vorher :) Mein Hinweis bezog sich auch eher darauf, dass es sinnvoll ist, die Ursachen eines Problems zu verstehen und das Problem dann gezielt zu beheben als dass man ausprobiert, bis die Fehlermeldung verschwindet. Letzteres hat potenziell ungewollte Nebenwirkungen.
Ja, das stimmt. Unser Problem ist bloß nachzuvollziehen wo das Problem genau herkam. In unserer Arbeitsgruppe gibt es eine weitere Studie, die eine leere Seite für Code benutzt und bei der die Situation ganz ähnlich aussieht. Aber das oben geschilderte Problem tritt dort nicht auf. Wissen Sie, woran das liegen könnte?
Ich habe jetzt eine Seite hinter die leeren Seiten eingefügt, auf der sich nur ein Text befindet. Deswegen machen die Fragen auf der Seite dahinter nun keine Probleme mehr. Wir testen die Studie jetzt noch einige Male und hoffen, dass das Problem damit behoben ist. Aber es wäre natürlich dennoch gut zu wissen warum nur in diesem Experiment der Fehler auftrat und nicht in dem anderen, wenn es ein generelles Problem mit leeren Seiten gibt.
...