0 votes
in SoSci Survey (English) by s083603 (130 points)

Hi!

I am having a trouble with incorporating a redirect link from an external provider.
Floowing the instructions from Manual I have created an internal variable (IV_01) with a variable
description encID. Then I created a php code on the first page of a questionnaire:

$id = readGET('encID');
replace('%encID%', $id);

put('IV01_01', $id);

On the page before 'End page' I have only a php code for redirect:

redirect('http://www.infovalidator.com/ic/survey.php?autoAnswer[292697][0]=0&encID=[%encID%]');

And it does not work.
Could you, please, provide any idea, what could be the problem?

Thanks!

1 Answer

0 votes
by SoSci Survey (311k points)

It would be helpful to specify the "not work": Is there any redirect at all?

If possible, please check which URL is actually called by the redirect. If it's not visible in the browser address bar, you can see it in the browser's developer toolbar -> network (terms slightly different, depending on your browser).

If it's just a wrong ID arriving at the panel provider, my assumption is that the brackets around the %encID%should be removed:

redirect('http://www.infovalidator.com/ic/survey.php?autoAnswer[292697][0]=0&encID=%encID%');

Please also clearify if the brackets around the numbers (after autoAnswer) are correct. I guess that the provider used them just to make clear that something must be inserted:

redirect('http://www.infovalidator.com/ic/survey.php?autoAnswer2926970=0&encID=%encID%');
asked Nov 21, 2017 in SoSci Survey (English) by s083603 (130 points) Redirect link

Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

...