Willkommen im Online-Support von SoSci Survey.

Hier bekommen Sie schnelle und fundierte Antworten von anderen Projektleitern und direkt von SoSci Survey.

→ Eine Frage stellen


Welcome to the SoSci Survey online support.

Simply ask a question to quickly get answers from other professionals, and directly from SoSci Survey.

→ Ask a Question

0 votes

Dear people from SoSci Survey,

Yves Wycisk from the University of Hannover has kindly shared with me his XML and audio files to upload to SoSci his “Headphones and Loudspeakers Test” (HALT) survey so I can test the quality of the headphones that my participants will wear during my experiments. I was able to upload the materials to SoSci and run the HALT survey. However, the audio files do not play. I double check the names of the audio files I uploaded and the names of the audio files as specified on the XML file and the they match perfectly. I would like to know whether you might know

(1) what the problem may be

and

(2) whether there is a way within SoSci to see how the audio files are linked to the questions. I looked at each specific question for HALT using SoSci "Section Management" but it only shows the words used in the question, nothing about audio files. Then I open the already created questions using SoSci “Create Questionnaire” and I was able to see the mp3 file player but it does not play the audio.

This is the link for the pretest of the survey I am referring to:

https://www.soscisurvey.de/IvanHALT/?act=4wBmajIR4Gn2A3x4hzbuAMxi

Thank you very much,

Ivan

in SoSci Survey (English) by s111290 (110 points)

1 Answer

0 votes

The browser error console sais that the file "Einstellstueck.mp3" cannot be retrieved from the server.

Could you please check, if you have uploaded that file as media file and (!) if a "pro://" is displayed before the filename in the media files listing?

If there's a "pro://" that you checked the box for the protected file upload. If a file is uploaded to the protected storage, you won't be able to share it's link somewhere on the Internet (which may be useful). But that also means that you will need a "pro://" in your HTML code as well.

by SoSci Survey (79k points)
Thank you for your response.

I just double checked the audio files once again. I went to
Ivan's HALT / Questionnaire / Image and Media Files / Listing of Files

I saw all the files I uploaded and I saw no "pro://" before any of the files names.

For instance, the first file that the survey uses shows as:

Einstellstuck.mp3     1.2 MB     audio file
followed by the download icon and the delete icon.

Any other ideas about what can be wrong?

I also do not know how to check/edit the HTML code of the survey within SoSci.
> Einstellstuck.mp3     1.2 MB     audio file

Okay, the file name in your code is "Einstellstueck.mp3" - please note the difference of "uck" and "ueck".
I apologize for my not noticing this before. I probably missed that due to my lack of familiarity with German words. I have corrected the names of the audio files and now they play in the survey without problem. Thank you very much for your help and patience!
...